RESOLVED: New VMs not getting deployed

RESOLVED: New VMs not getting deployed

Version: 2023-08-24

TL;DR

RESOLVED: Connect via Bastion, the cause is Azure Portal, beyond our control and for Microsoft to fix
RESOLVED: Creation of new VMs are failing, potentially due to an update pushed by Microsoft earlier than expected.  We apologise for any inconvenience this might cause you.

Updates

2023-08-25 @ 03:53

Bastion works fine again.

2023-08-25 @ 03:01

Successfull VM deployments in production. Later today a full write up of the cause and possible lessons learned.
Windows RDP-client access works fine, but we notice that Azure Bastion is very slow/unresponsive. We raised the issue, but at anDREa we cannot do more than this because Azure Portal is beyond our control.

2023-08-25 @ 02:22

Solution tested successfull and pushed to production.

2023-08-24 @ 21:38

Possible solution found, running some tests.

2023-08-24 @ 20:10

Still trying to identify the problem that is caused by Microsoft.

2023-08-24 @ 14:24

Issue reproduced by local Support Team and issue handed over to anDREa.

2023-08-24 @ 09:42

Issue first reported. 

What happened?

On 2023-03-23 at 09:42 (Amsterdam Time Zone), the local Support Team received the first ticket of new VMs failing to be created. At 14:24, the issue was reproduced by the local Support Team and handed over to anDREa. 

VM deployments are failing with the message:
 
  • Diagnostic settings does not support retention for new diagnostic settings. (Code: BadRequest)

Cause

Microsoft reported the following:


It looks like this update has been pushed earlier than expected.

Resolution

The anDREa development team is working hard to resolve the issue.

Impact

So far, we have received 1 support ticket regarding this issue. However, we believe that this impacts all Workspaces.

Next steps

TBD.


    • Related Articles

    • POST DEPLOYMENT ISSUES (RESOLVED)

      Issue Over the weekend we have pushed improvements to production. Unfortunately during the Post Deployment Test we encountered the following problems: Newly created Linux VMs cannot be accessed (will be worked upon on 2021-11-16) (RESOLVED) Linux VM ...
    • RESOLVED: File Share not accessible

      The issue A number of users experience after the migrations the following: No files/folders visible in the Files Tab No share with files/folders visible in the VM The above is an access issue, no data is lost. Update: 2021-03-25 @12:39 Root cause ...
    • Linux VMs

      On the myDRE platform different types of Linux virtual machines (VMs) are available. CentOS 7.5 (is reaching its end of life) Ubuntu 20 (for GPU usage) Ubuntu 22 By default, Linux VMs have no connection to the outside world, so cannot be directly ...
    • What is new on mydre.org?

      Last updated 20-04-2021 New features have been added or improved.  View the announcement at: Improved & New Features. Last updated 30-03-2021 New features have been implemented after the migration from researchenvironment.org to mydre.org. Therefore, ...
    • Getting started - general guide

      Introduction Purpose of this article is to provide you of the most essential links and knowledge to get you first started on myDRE platform. Getting started Requesting a new myDRE account Activating your @myDRE account What is a workspace? How to ...