Z:-drive not available in newly created VM from image

Z:-drive not available in newly created VM from image

Bug description

A VM based on an image does not mount the Z-drive for those who were part of the VM from which the image was created. However this is visible:


Related to:
  1. Create VM-templates for your Workspace
  2. Creating VM images for Shared Gallery

Cause

For some reason that we still have to identify, the image retains a 'memory' of Z-drive for those profiles that were part of the VM prior creating the image.

To check for the error:
  1. Go to c:\scripts
  2. run the .ps1 file (right click, run)



Resolution

Below is the resolution that only needed to be done once.

Open powershell windows (type powershell at command key; cmd)
  1. net use
if z:-drive is disconnected then:
  1. net use /delete z:
To mount the drives, in Explorer:
  1. Go to c:\scripts
  2. run the .ps1 file (right click, run as admin)
Normally this would resolve the issue.

If the above fails to show the z: and i: drive, please restart the VM; z-drive should now be available, quickest way (more steps, but much quicker time wise):
  1. Click on the VM in myDRE portal.
  2. Click the icon manage & monitor VM (the phone icon).
  3. Click on the link underneath the QR code.
  4. In the new tab, look on top, left of middle for restart.

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