[Resolved] Data upload & download issue
What happened
At 10:04 on 2022-11-07 it was first reported that upon download request, the status of the request remains at file copy pending, causing downloads not to come through.
Cause
The Azure Function that is responsible for handling copy operations by invoking a serverside transfer between the Workspace Storage Azure File share and the transient container for data transfer is configured to be triggered whenever there is a new message in a queue intended for these operations. The function as observed was not getting triggered by new messages.
Resolution
There has not been a code change to that sub system since April 2022, which could cause the issue. We chose to restart the function to check the log stream. After restarting, the function picked up all the pending queue messages and processed them succcessfully.
Impact
Data transfer requests between 10:04-13:00 on 2022-11-07 were all queued up and affected by the issue. All have now been processed. We have received 1 ticket reporting this issue in this timeframe.
Next steps
We are going to work on a monitoring mechanism to observe this and other queues for messages that are unprocessed for longer than a certain duration to trigger evasive actions.
Event log - real time updates
2022-11-07 @ 13:00
The issue has been resolved and all download requests with the status file copy pending should now have been processed and ready to download.
Final update of this article will entail the cause of the issue.
2022-11-07 @ 10:27
Issue reproduced by local support team member and reported to anDREa second line support; investigation has started.
It seems that the issue might also effect data uploads.
2022-11-07 @ 10:04
File copy pending issue first reported.
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